ADSB Receiver project & Buster

Hello Folks.

  Recently I was stuck on 2.6.3 and figured a good way to finally get to 2.7.2 would be to start with a fresh NOOBs install with Buster.

 I kept running into errors during the install before giving up. It seems some of the repositories may be installing Stretch versions. I am not sure if this is an issue or not.

 Flightaware was the first package that would not install. I figured if its just one feed I could live without it since I have a nearby feeder also feeding Flightaware on its own Pi.

 Openskyfeeder failed in the same manner. Lastly the ADSB Database itself errored out. They would retry a few times and then the script would stop.

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package php7.0-cgi
E: Couldn’t find any package by glob ‘php7.0-cgi’
E: Couldn’t find any package by regex ‘php7.0-cgi’

Checking if the package php7.0-cgi is installed… [INSTALLATION ATTEMPT FAILED]
Attempting to Install the package php7.0-cgi again in 5 seconds (ATTEMPT 2 OF 5)…

There’s a pull request fixing this problem, https://github.com/jprochazka/adsb-receiver/pull/520

Basically there’s a line to add in the portal install.sh script.

This is normal since buster is shipping PHP7.3 instead of 7.0